2. написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

PROvacaTOR1 PROvacaTOR1    1   17.05.2019 11:10    4

Ответы
anokhina69 anokhina69  30.09.2020 19:06

Var max,h:integer;

begin

max:=-maxint-1;

repeat

begin

read(h);

if(h>max) then max:=h;

end;

until h >0;

writeln(max);

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ПОКАЗАТЬ ОТВЕТЫ
Alekseev709 Alekseev709  30.09.2020 19:06

using System.Collection.Generic; 

 

List<int> arr = new List<int>();

 

int max = Convert.ToInt32(Console.ReadLine()); // максимальный порог

 

for(int i = 0; i < max;i++)

{

arr.Add(Convert.ToInt32(Console.ReadLine()));

}

arr.Sort();

Console.WriteLine(arr[max]);

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика