1составить программу при поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . в массиве a[n] записаны оценки экзаменующихся , полученные на первом экзамене . подсчитать , сколько человек не допущено ко второму экзамену . 2 в одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) минимальный элемент массива; 2)сумму элементов массива , расположенных между первым и последним положительными элементами . преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

Viktoria11112222000 Viktoria11112222000    2   21.05.2019 16:20    8

Ответы
Lera123yf Lera123yf  16.06.2020 09:45

Задача1

массив определи как array[];

чтобы посчитать, просто используй счетчик, но сначала инициализируй переменную, которая содержит ответ задачи:

int n;

array [n];

int answer;

for (i=0, i < n, i++)

{

     if (array[i] == 2)

         answer++;

std::cout<<answer;

Как то так

 

Задача2 

 

array[n];

 

 

for (int i =1, i < n, i++)

{

 if (array[0] >= array[i])

    array[0] = array[i];

}

std::cout << array[0];

//Это было решение первого пункта

int first;

int last

bool positive;

while (positive == false )

{

   for (int i = 0; i < n; i++)

     {

        if (array[i] > 0)

        {

          positive = true;

          first = i;

          array[i] = -1;

      }

}

while (positive == false )

{

   for (int i = 0, i < n, i++)

     {

        if (array[i] > 0)

        {

          positive = true;

          last = i;

      }

}

 

 

int summ

for (int i = first, i < last, i++)

{

  summ += array[i];

}

 std::cout<<summ; // ответ на 2 пункт

// ПРеобразую

newarray [n];

int a = 0;

for (int i = 0, i < n, i++)

{      

 if (array[i] == 0)  

   {      

newarray[a] = array[i];      

 a++;      

    }  

for (int i = 0, i < n, i++)

{    

     if (array[i] != 0)    

         {        

          newarray[a] = array[i];

         a++;

        }

}

std::cout<< newarray;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика