17. напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.

Andrey26022002 Andrey26022002    1   26.08.2019 11:20    6

Ответы
ussr9989 ussr9989  09.09.2020 07:33
Program n1;
var sum,a: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if(a=3) or (a=6) or (a=9) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика