13. дано число n. составьте программу для вычисления суммы: s = 1 + 2 + 3 + + n. 14. составьте программу в gpaph abc. нарисовать ряд закрашенных в зеленый цвет кругов радиуса 20 пикселей вдоль верхнего края экрана монитора 16. составьте программу для вычисления числа n: n = 1∙2∙3∙…∙х. число х вводится с клавиатуры.

simonenkoeliza simonenkoeliza    3   02.09.2019 14:20    3

Ответы
Фокс890 Фокс890  03.08.2020 14:38
program summa;
var
sum:BigInteger;
i,n:integer;

begin
write ('n = ');
readln(n);  
sum:=0;    
i:=1;       
while i<= n do begin 
sum:=sum+i;         
i:=i+1;    
end;
writeln('Sum = ',sum);
end.


program krugi;
uses graphabc;
var
x,y,r:integer;

begin
setBrushColor(clGreen);  
x:=22; y:=22; r:=20;  
while x<660 do    begin     
circle(x,y,r);  
x:=x+40;        
end;
end.


program factorial;
var
pr:BigInteger;
i,n:integer;

begin
write ('n = ');
readln(n);  
pr:=1;    
i:=1;       
while i<= n do begin 
pr:=pr*i;         
i:=i+1;    
end;
writeln('Факториал числа n! = ',pr);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика