12 . напишите программу, определяющую колличество отрицательных чисел для введенных с клавиатуры 10 отрицательных чисел

venerochka02 venerochka02    3   06.08.2019 11:30    6

Ответы
guljanatkabdrasheva guljanatkabdrasheva  04.10.2020 00:58
Var
    i, k, n: integer;

begin
    k := 0;
    
    for i := 1 to 10 do
    begin
        write('Введите число');
        readln(n);
        if n < 0 then k := k + 1;
    end;
    
    writeln(k);
end.

Задачу понимаю так - вводится 10 чисел, посчитать сколько из них отрицательные
ПОКАЗАТЬ ОТВЕТЫ
стас2118 стас2118  04.10.2020 00:58

Program symma;
var
   a, s: integer;
begin

   s:=0;
   for i:=1 to 10 do
     begin
     write('введите отрицательное число');
     readln(a);
     s:=s+a;
   end;

writeln('s=',s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика