№109. написать программу, которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее арифметическое.рекомендуемый вид экрана во время работы программы ниже. данные, введенные пользователем выделены полужирным шрифтом.вычисление среднего арифмитического последовательности дробных чисел. после ввода каждого числа нажимайте . -> 5.4 -> 7.8 -> 3.0 -> 1.5 -> 2.3 среднее арифмитическое введенной последовательности: 4. 00 для завершения работы программы нажмите < enter> .

anyanaffanya anyanaffanya    2   13.03.2019 13:11    22

Ответы
ddurua ddurua  25.05.2020 04:26

#include <iostream>

using std::cin, std::cout, std::endl;

int main(){

   long double sum = 0;

   for(size_t i = 0;i<5; ++i){

        cout   << "-> ";

        double a;

       cin >> a;

       sum+=a;

   }

 cout << sum/5 << endl;

   return 0;

}

Но не вовсем понятно, что нужно делать после ввода каждого числа, я написал, что нужно вводить <Enter> после каждого

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика