tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив из десяти целых чисел:
Дан массив из десяти целых чисел: {2; -3; 5; 0; 7; -4; 1; -1; -6; 9}. найти произведение ненулевых элементов массива
kristina200614
2 13.07.2019 11:50
3
Ответы
17312
03.10.2020 02:55
Var
a:array[1..10] of integer;
i,d:integer;
begin
d:=1;
for i:=1 to 10 do begin
writeln(i ,' число массива = ');
read(a[i]);
if(a[i]<>0) then d:=d*a[i];
end;
writeln(' Произведение равно ', d);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
maevava
15.12.2019 06:20
Как заряжать наушники hoco s24? когда я их ложу в чехол они загораются красным. как узнать что они зарядились. ...
jayature
15.12.2019 06:31
Составить программу, которая проверяет знак заданного пользователем целого числа (положительное / отрицательное), если это число водит в указанный диапазон: –60...
nankasvanka
04.03.2021 11:33
будтласка до іть хто можи живо зробити з інформатики сторінка 107 8 клас треба тіпа у текстовому документі зробити призинтацію розкласти корочі це усо будтласка...
avorob
04.03.2021 11:33
РЕБЯТ ,СНОВА ИНФОРМАТИКА))) !...
caesar2
04.03.2021 11:34
Для заданной схемы, составленной из трех логических элементов ЛЭ1, ЛЭ2, ЛЭ3 за писать логическое выражение и составить таблицу истинности. Типы элементов ЛЭ1, ЛЭ2...
andkrutoi2018
18.05.2020 16:32
Графический планшет(гидитайзер)- устройство: 1. для компьютерных игр 2. при проведении инженерных расчётов 3. для передачи символьной информации в компьютер4.для...
NastyaD05
29.03.2021 13:36
3. Key questions of the theme: 1. What are the advantages of using computerized Spreadsheets? 2. What are the four different types of operators use in Excel 2010?...
720612
29.03.2021 13:31
іть зродити це в мові Паскаль ...
lilo2622
23.02.2020 20:48
Дано число n.Если n 7,то увеличить его на 2,в противном случае уменьшить в два раза...
Пиоооьлл
02.03.2021 18:49
Рассмотрим блок-схему на рис. 2.7 и алгоритм на AЯ. началоВвод Nалг СЛОВАцел F, N, Rначввод NF:=1R:=1F:=1R:=1нетучае-Говок.фак-пока R =N повторятьнцF:=F*RR:=R+1кцRSNдаF:=F*Rвывод...
Популярные вопросы
Від поданих слів утворити три слова скфіксальним клен, береза,голуб,...
1
Скорость поступательного движения автомобиля возросла в 3 раза.как...
3
1) гепард бежит со скоростью 1325 м\ мин.какое расстояние он...
3
Рассчитать протяженность южной америки по экватору. !...
2
Объясните разницу между словами вдохнуть и вздохнуть, вдох и...
2
Мяч бросают вертикально со скоростью 5 м\с. зависимость высоты...
1
Решить . во время распродажи в магазине все товары продавались...
3
Как называется пролив который соединяет два моря два океана и...
2
Как пишется слово (без) просыпа? приставка без раздельно или...
2
Ca + o2 - 2cao от куда берётся 2 перед ca ?...
2
a:array[1..10] of integer;
i,d:integer;
begin
d:=1;
for i:=1 to 10 do begin
writeln(i ,' число массива = ');
read(a[i]);
if(a[i]<>0) then d:=d*a[i];
end;
writeln(' Произведение равно ', d);
end.