10 класс напишите программу обработки последовательности целых чисел. на вход программе сначала подается натуральное число n - кол-во элементов последовательности, n не превосходит 1000. затем следуют натуральные числа, каждое число в отдельной строке. каждый элемент последовательности не превосходит 10000. программа должна выводить все элементы последовательности, являющиеся трехзначными числами, кратными семи, в порядке, обратном порядке ввода. если таковых нет, программа выводит число -1 заранее !

Romaglot Romaglot    2   30.06.2019 13:20    1

Ответы
princhesnurss princhesnurss  02.10.2020 16:12
Program primer;
Var a:array[1..1000] of integer;
    i,m,k,n: integer;
Begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=n downto 1 do begin  //в обратном порядке
k:=0;
m:=a[i];
while m>0 do begin
m:=m div 10;
inc(k);  // ищем количество разрядов 
end;
if ((a[i] mod 7) =0) and (k=3) then write(a[i]:2);//кратно 7 и 3 разряда - выводим
end;
end.
ABC Pascal
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика