1. Заполните массив кубами случайных целых чисел в интервале (1,5). Перемножьте все элементы списка с четными индексами (то есть A[0], A[2], A[4], ...). Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

2. Заполните массив из 10 элементов. Выведите на экран произведение четных элементов.
Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

ответом на задачи является программа на языке python.

Ta4er11 Ta4er11    1   12.12.2021 21:31    15

Ответы
Татьяна64101 Татьяна64101  01.02.2022 07:51

Программа:

Python:

№1)

A = list(input().split())

pr = 1

for i in range(len(A)):

   if i % 2 == 0:

       pr *= int(A[i])

print(f'{A}\n{pr}')

№2)

from random import randint

arr = [randint(-10, 10) for i in range(10)]  # массив из 10 чисел от -10 до 10

pr = 1

for i in arr:

   if i % 2 == 0 and i != 0:  pr *= i

print(f'{arr}\n{pr}')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика