1. составьте программу, решающую следующую : с кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. какое наименьшее количество (k) коробок потребуется для перевозки n килограмм конфет? вводимое и в ыводимое . для заданного числа суток определить количество часов, минут и секунд. вводимое количество сутоквыводимое количество часов, минут, секунд7 суток= 168 часов = 10080 минут = 604800 секунд1 сутки= 24 часов = 1440 минут = 86400 секунд10 суток= 240 часов = 14400 минут = 864000 секунд2 суток= 48 часов = 2880 минут = 172800 секунд

cifirka5 cifirka5    3   16.07.2019 11:00    8

Ответы
tashkaostrovska tashkaostrovska  03.10.2020 05:37
Вроде должна работать это 1 задача

uses crt;
var a,i,j,n:integer;
begin
writeln('ВВедите кол. конфет в (кг)');
read(a);
n:=0;
if a>=10 then begin n:=n+ a div 10; a:=a-(a div 10*10); end;
if (a>=5) and (a<10) then begin n:=n+ a div 5; a:=a-(a div 5*5); end;
if (a>=1) and (a<5) and (a<10) then begin n:=n+ a div 1; a:=a-(a div 1*1); end;
writeln('Общее количество коробок = ',n);
end.

2 задача
uses crt;
var a,i,j,n:integer;
begin
writeln('Введите кол. суток');
read(a);
writeln('Количество часов в ',a,' сутках = ',a*24);
writeln('Количество минут в ',a,' сутках = ',a*24*60);
writeln('Количество секунд в ',a,' сутках = ',a*24*60*60);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика