1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2

koroleva1858 koroleva1858    1   04.09.2019 11:40    2

Ответы
vavkina2016 vavkina2016  06.10.2020 16:48
Program z9;  Var a,del,del_2,i,j:integer; b,b_2: string;Begin  write('Введите число - '); readln(a);    del:= 5;  del_2:= 2;  i:= 0;  j:= 0;    while (a >= del) do  begin    if (a mod del = 0)       then       begin        b:= b + del + ' ';        i:= i + 1;      end;     del:= del + 10;  end;    while (a >= del_2) do  begin    if (a mod del_2 = 0)       then       begin        b_2:= b_2 + del_2 + ' ';        j:= j + 1;      end;     del_2:= del_2 + 2;  end;    writeln('Кол-во делителей заканчивающихся на 5 - ', i);  writeln(b);  writeln;  writeln('Кол-во делителей заканчивающихся на 2 - ', j);  writeln(b_2);  writeln;End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика