1.составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных элементов настоящей таблице х [1 .. 10] на 0. 3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат. 4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

olgamorozkina19 olgamorozkina19    2   18.05.2019 06:50    2

Ответы
121517 121517  11.06.2020 13:17

//первая программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    inc(x[i]);
  end;
 
  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

 

 

 

//вторая программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    if x[i] > 0 then
      x[i] := 0;
  end;

  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

 

 

 

// третья программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    if x[i] < 0 then
      x[i] := x[i] * x[i];
  end;

  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

 

 

 

// четвертая программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    if x[i] > 10 then
      x[i] := x[i] + 2;
  end;

  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика