1)составить программу для поиска наибольшего из 4 чисел. 2) cоставить программу поиска наибольшего из трех чисел с учетом того, что числа могут быть равны. только плз чтобы там было типо такого : var a,b,c,d max: integer

301436168 301436168    3   12.08.2019 14:10    3

Ответы
juehxbrf juehxbrf  04.10.2020 13:39
1)
var
  a, b, c, d, max: integer;
 begin
  readln(a, b, c, d);
  if(a > b) and (a > c) and (a > d) then max := a
  else if(b > a) and (b > c) and (b > d) then max := b
  else if(c > a) and (c > b) and (c > d) then max := c
  else max := d;
  write(max);
end.
2)
var
a, b, c, max:
integer;
 begin
  readln(a, b, c);
  if(a > b) and (a > c) then max := a
  else if(b > a) and (b > c) then max := b
  else max := c;
  write(max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика