1. составить программу для нахождения корней квадратного уравнения с использованием уравнений виета. на входе - коэффициенты уравнения, на выходе - корни.2. составить программу, определяющую, какой четверти декартовой системы координат принадлежит точка (х, у). на на входе - координаты точки, а на выходе - номер четверти​

VoinBogov VoinBogov    1   15.05.2019 10:36    1

Ответы
danilpro2017 danilpro2017  10.06.2020 07:19

Объяснение:

var a,b,c: real;

   x1,x2,D: real;

begin

 readln(a,b,c);

 D := b*b - 4*a*c;

 if D<0 then

   writeln('Корней нет')

 else if D=0 then begin

   x1 := -b/2/a;

   writeln('x1=x2=',x1);

 end

 else begin

   x1 := (-b-sqrt(D))/2/a;

   x2 := (-b+sqrt(D))/2/a;

   writeln('x1=',x1,' x2=',x2);

 end;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика