1. составить алгоритм и программу для вычисления значения функции по заданному значению аргумента.
2. составить алгоритм вычисления функции по заданным параметрам и значению аргумента
(паскаль) ​

somofsomof somofsomof    3   18.10.2019 15:01    7

Ответы
Петя228001 Петя228001  10.10.2020 07:48

program Calc1;

var

 m, k, x, y: Double;

begin

 Write ('Введите m, k, x: ');

 ReadLn (m, k, x);

 if m * k - x >= 2 then

   y := Sqr (x) + Sin (6 * x) - (k + 1)

 else

   y := Power (x, 3) - m * k + 3;

 WriteLn ('y = ', y :20 :10);

 ReadLn;

end.

program Calc2;

const

 E = 1;

 F = -2;

var

 x, y: Double;

begin

 Write ('Введите x: ');

 ReadLn (x);

 if x > Pi then

   y := Sqr (Pi) + E * x * Ln (x)

 else if x < 0 then

   y := 0

 else

   y := Pi / 4 - F * x;

 WriteLn ('y = ', y :20 :10);

 ReadLn;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика