1)(паскаль) дан целочисленный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 – учащихся выпускного класса за итоговый тест по информатике. напишите программу, которая находит и выводит номера двух соседних элементов массива, сумма которых минимальна. исходные данные объявлены так, как показано ниже. запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них. const n=30; var a: array [1..n] of integer; i, j, min, min2, s: integer; begin for i: =1 to n do readln(a[i]); end.

Вова21123 Вова21123    3   27.05.2019 03:30    3

Ответы
iragabets73 iragabets73  23.06.2020 20:15
Использовал две переменные из пяти возможных.

const N=30;
var a: array [1..N] of integer;
i,j:integer;
begin
for i:=1 to N do read(a[i]);
j:=1;
for i:=1 to N-1 do if a[i]+a[i+1]<a[j]+a[j+1] then j:=i;
write(j,' ',j+1)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика