1. ниже записана программа. получив на вход число x, эта программа печатает два числа. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7. var x, l, m: integer; begin readln(x); l: =0; m: =0; while x > 0 do begin l: =l+1; if m < (x mod 10)
then begin m: =x mod 10; end; x: = x div 10; end; writeln(l); write(m); end. ответ: 2. ниже записана программа. получив на вход число x, эта программа печатает два числа. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7. var x, a, b : integer;
begin readln(x); a : = 0; b : = 1; while x > 0 do begin a : = a + 1; b : = b * (x mod 10); x : = x div 10; end; writeln(a); write(b); end. ответ: 3. ниже записана программа. получив на вход число x, эта программа печатает два числа. укажите наименьшее из таких чисел x, при вводе
которых алгоритм печатает сначала 3, а потом 7. var x, l, m: integer; begin readln(x); l: =0; m: =0; while x > 0 do begin l: = l + 1; m: = m + x mod 10; x: = x div 10; end; writeln(l); write(m); end. ответ: 4. ниже записана программа. получив на вход число x, эта программа печатает
два числа. укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 36. var x, a, b : integer; begin readln(x); a : = 0; b : = 1; while x > 0 do begin a : = a + 1; b : = b * (x mod 10); x : = x div 10; end; writeln(a); write(b); end. ответ: 5. ниже
записана программа. получив на вход число x, эта программа печатает два числа. укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 21. var x, a, b: integer; begin readln(x); a: =0; b: =1; while x> 0 do begin a: =a+1; b: =b*(x mod 10); x: = x div 10
end; writeln(a); write(b); end. ответ: 6. ниже записана программа. получив на вход число x, эта программа печатает два числа. укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 35. var x, a, b: integer; begin readln(x); a: =0; b: =1; while x> 0
do begin a: =a+1; b: =b*(x mod 10); x: = x div 10 end; writeln(a); write(b); end. ответ: 7. ниже записана программа. получив на вход число x, эта программа печатает два числа. укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 6, а потом 5. var x, a, b: integer;
begin readln(x); a: =0; b: =0; while x> 0 do begin a: = a + 2; b: = b + (x mod 10); x: = x div 10; end; writeln(a); write(b); end.

Sdq2 Sdq2    2   08.10.2019 19:30    99

Другие вопросы по теме Информатика