Написать программу,находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя.(авс паскаль)

qweasdzxcrfvtgbmn qweasdzxcrfvtgbmn    3   24.09.2019 13:50    3

Ответы
talanovaelena2 talanovaelena2  08.10.2020 15:24
Program fgg;

var
x: String[10];
t, v, s: Real;

begin
Write('Что будем искать?: ');
ReadLn(x);
if x = 'скорость' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите время: ');
ReadLn(t);
WriteLn('Скорость=', s / t);
end
else if x = 'время' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите скорость: ');
ReadLn(v);
WriteLn('Время=', s / v);
end
else if x = 'расстояние' then
begin
Write('Введите скорость: ');
ReadLn(v);
Write('Введите время: ');
ReadLn(t);
WriteLn('Расстояние=', v * t);
end
else
WriteLn('Неверно указано, что будем искать.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика