1. напишите программу на языке паскаль, которая позволяет найти минимальное число массива х, состоящего из 30 элементов.

2. напишите программу на языке паскаль, которая позволяет найти сумму чисел массива х, состоящего из 20 элементов.

sapetnyymark sapetnyymark    1   30.01.2020 23:20    572

Ответы
Музалевская Музалевская  11.10.2020 03:56

1.

program MinElement;

var

X: array[1..30] of Integer;

i, min: integer;

begin

randomize;

for i := 1 to 30 do

X[i] := random(100);

min := X[1];

for i := 1 to 30 do

if X[i] < min then

min := X[i];

writeln('Минимальное число: ', min);

write('Все элементы:');

for i := 1 to 30 do

write(' ', X[i]);

readln;

end.

2.

program Summa;

var

X: array[1..20] of Integer;

i, sum: integer;

begin

randomize;

for i := 1 to 20 do

X[i] := random(100);

sum := 0;

for i := 1 to 20 do

sum := sum + X[i];  

writeln('Сумма всех чисел: ', sum);

write('Все элементы:');

for i := 1 to 20 do

write(' ', X[i]);

readln;

end.

Всё правильно и проверено лично!

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика