1) дан одномерный массив из 12 элементов. составить программу заполняющую массив целыми числами в интервале -20 до 15 2)требуется подсчитать кол-во пятерок , четверок, тоек полученных за контрольную работу, если число учеников равно 8 3)дан одномерный числовой массив,изменить знак элементов массива к[1; 12] на противоположный

mirgin2002 mirgin2002    3   18.05.2019 13:20    3

Ответы
Ольга25052000 Ольга25052000  30.09.2020 20:16

var

  a:array[1..12] of integer;

  i:integer;

begin

  randomize;

  writeln('Сгенерированный массив:');

  for i := 1 to 12 do

  begin

    a[i] := random(36) - 15;

    write(a[i], ' ');

  end;

  writeln;

end.

 

//вторая программа

const

  n = 8;

var

  a:array[1..n] of integer;

  i, count3, count4, count5:integer;

begin

  randomize;

  writeln('Оценки учеников:');

  for i := 1 to n do

  begin

    a[i] := random(3) + 3;

    write(a[i], ' ');

    if a[i] = 5 then

      inc(count5);

    if a[i] = 4 then

     inc(count4);

    if a[i] = 3 then

      inc(count3);

  end;

  writeln;

  writeln('Троек - ', count3);

  writeln('Четверок - ', count4);

  writeln('Пятерок - ', count5);

end.

 

 

 

 

//третья программа

var

  k:array[1..12] of integer;

  i:integer;

begin

  randomize;

  writeln('Сгенерированный массив:');

  for i := 1 to 12 do

  begin

    k[i] := random(36) - 15;

    write(k[i], ' ');

  end;

  writeln;

  writeln('Преобразованный массив:');

  for i := 1 to 12 do

  begin

    k[i] := k[i] * (-1);

    write(k[i], ' ');

  end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика