1) напишите программу которое вводит натуральное число"n" и находит сумму всех натуральных чисел от 1 до n (цикл пока). 2)напишите программу которое вводит натуральное число "n" и выводит первые "n" четных натуральных чисел. 3)напишите программу которая вводит натуральные числа "a и b" и выводит квадраты натуральных чисел в диапазоне от "a до b". , а то не

vadim252525 vadim252525    3   21.07.2019 13:10    1

Ответы
vasilinabv vasilinabv  25.08.2020 11:52

1)

var

   a, n, s: integer;

begin

   write('n = ');

   Readln(n);

   

   a := 1;

   while a <= n do

   begin

       s := s + a;

       a := a + 1;

   end;

   writeln(s);

end.

2)

var

   a, n: integer;

begin

   write('n = ');

   Readln(n);

   a := 1;

   while a <= n do

   begin

       writeln(2 * a);

       a := a + 1;

   end;

end.

3)

var

   a, b: integer;

begin

   write('Введите числа a и b: ');

   Readln(a, b);

   

   while a <= b do

   begin

       writeln(a, '^2 = ', sqr(a));

       a := a + 1;

   end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика