1)Напишите программу которая запрашивает с консоли два целых числа (int n и int m) и выводит на экран все НЕЧЕТНЫЕ числа от n до m. 2)Напишите программу которая запрашивает с консоли два целых числа (int n и int m) и выводит на экран все числа от n до m которые делятся на 3 без остатка.
с++

диль9 диль9    1   28.07.2022 03:54    21

Ответы
ВіКтОрІя0901 ВіКтОрІя0901  28.07.2022 06:00

#include "iostream"

using namespace std;

int main() {

int n, m;

cout << "Task 1" << endl;

cout << "n = ";

cin >> n;

cout << "m = ";

cin >> m;

cout << "" << endl;

if (m%2 != 0) {cout << "m = " << m << ", ";}

if (n % 2 != 0) { cout << "n = " << n << endl; }

else if (n % 2 != 0 and m % 2 != 0) {cout << "n = " << n << endl;cout << "m = " << m << endl;}

else if (n % 2 == 0 and m % 2 == 0) {cout << "Nothing" << endl;}

cout << "Task 2" << endl;

cout << "n = ";

cin >> n;

cout << "m = ";

cin >> m;

cout << "" << endl;

if (m % 3 == 0) { cout << "m = " << m << ", "; }

if (n % 3 == 0) { cout << "n = " << n << endl; }

else if (n % 3 == 0 and m % 3 == 0) { cout << "n = " << n << endl; cout << "m = " << m << endl; }

else if (n % 3 != 0 and m % 3 != 0) { cout << "Nothing" << endl; }

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика