1)Напишите программу, которая заполняет матрицу из N строк и M столбцов нулями и единицами в шахматном порядке.
2)Напишите программу, которая заполняет матрицу из N строк и N столбцов нулями и единицами так, что все элементы выше главной диагонали равны нулю, а остальные – единице.

3)Напишите программу, которая заполняет матрицу из N строк и N столбцов нулями и единицами так, что все элементы выше побочной диагонали равны нулю, а остальные – единице.

hokip hokip    3   27.02.2021 09:30    38

Ответы
SoloveiG SoloveiG  29.03.2021 09:31

N = int(input('Введите N (строки): '))

M = int(input('Введите M (столбцы): '))

array_1 = []

array_2 = []

array_3 = []

el = 0

for i in range(N):

   a = []

   if M % 2 == 0 and i > 0:

       if el == 0:

           el = 1

       else:

           el = 0

   for _ in range(M):

       a.append(el)

       if el == 0:

           el = 1

       else:

           el = 0

   array_1.append(a)

print('Задание 1.')

for row in array_1:

   for el in row:

       print(el, end = ' ')

   print()

for i in range(N):

   a = []

   for j in range(N):

       if j > i:

           a.append(0)

       else:

           a.append(1)

   array_2.append(a)

print()

print('Задание 2.')

for row in array_2:

   for el in row:

       print(el, end = ' ')

   print()

           

for i in range(N):

   a = []

   for j in range(N):

       if j < N - i - 1:

           a.append(0)

       else:

           a.append(1)

   array_3.append(a)

print()

print('Задание 3.')

for row in array_3:

   for el in row:

       print(el, end = ' ')

   print()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика