1)напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105 2)напишите программу, которая вводит натуральное число n и находит сумму всех натуральных чисел от 1 до n . входные данные входная строка содержит единственное целое число n . выходные данные программа должна вывести сумму натуральных чисел от 1 до введённого числа n . примеры входные данные 100 выходные данные 5050 3)напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b . входные данные входная строк содержит два натуральных числа – границы диапазона a и b . гарантируется, что a ≤ b . выходные данные программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] . примеры входные данные 2 5 выходные данные 54 4)напишите программу, которая вводит натуральные числа a , b и n , и выводит на экран n псевдослучайных целых чисел на отрезке [ a , b ] . входные данные входная строка содержит три числа, разделённые пробелами: границы отрезка a и b и требуемое количество чисел n . гарантируется, что a ≤ b . выходные данные программа должна вывести n случайных целых чисел в одной строке, разделив их пробелами. примеры входные данные 10 20 5 выходные данные 10 10 19 12 13 за всё решение 99 ! решить

Nastya45t7 Nastya45t7    3   20.09.2019 17:30    10

Ответы
netesa0202 netesa0202  08.10.2020 05:24
1)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
if (a<0)and(b<0) then
 begin a:=-a; b:=-b; end;
if a<0 then for var i:=1 to b do s+=a
else for var i:=1 to a do s+=b;
WriteLn(s);
end.

Пример:
-7 15
-105

2)
var n,s:integer;
begin
Readln(n);
s:=0;
for var i:=1 to n do s+=i;
WriteLn(s);
end.

Пример:
100
5050

3)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
for var i:=a to b do s:=s+i*i;
writeLn(s);
end.

Пример:
2 5
54

4)
var a,b,n:integer;
begin
Readln(a,b,n);
for var i:=1 to n do write(random(b-a+1)+a,' ');
end.

Пример:
10 20 5
11 12 14 14 18
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика