1. написать программу вывода первых t элементов одномерного массива из 10 элементов, введенных с клавиатуры 2. написать программу формирования значений элементов одномерного массива с использованием генератора случайных чисел в интервале от -10 до 10 (функция random). количество элементов массива 10. вычислить среднее значение неположительных элементов. 3. написать программу формирования значений элементов одномерного массива в произвольном интервале целых чисел (ввод с клавиатуры). количество элементов массива 10. выписать индексы положительных элементов массива, кратных 3. 4. даны два одномерных массива из целых чисел разной размерности. найти целую часть среднего арифметического элементов каждого массива и их сумму. 5. заполните массив из n элементов случайными числами в интервале [1,n] так, чтобы в массив обязательно вошли все числа от 1 до n (постройте случайную перестановку). пример: массив: 3 2 1 4 5

magasadrudinov magasadrudinov    3   28.06.2019 19:10    7

Ответы
button4ik button4ik  02.10.2020 14:29
Такое задание уже было. Я на него отвечал, думаю модераторы не против, если свой же ответ здесь предоставлю)
  Только первых три

Задача 1:
var p: array[1..10] of integer;  
i:integer;
count:integer;
begin
for i:=1 to 10 do read(p[i]);
write('Сколько цифр массива хотите видеть? -> '); 
readln(count);
for i:=1 to count do write(p[i]:3);
end.

Задача 2:

var arr: array[1..10] of integer;   
i:integer;    
s:integer;    
count:integer;
begin
for i:=1 to 10 do
begin
arr[i]:=Random(-10,10);
if(arr[i]<0) then
begin
writeln(arr[i]:4);
s:=s+arr[i];
count:=count+1;
end;
end;
writeln('Среднее значение = ', s/count);
end.

Задача 3:

var arr: array[1..10] of integer;    
i:integer;    
crat:integer;    
id:integer;       
begin   
for i:=1 to 10 do   
begin   
read(arr[i]);   
crat:=arr[i] mod 3;   
if(crat = 0) then   
begin   
id:=arr[i];     
if(arr[i] = id) then writeln('Id = ', i:2);    
end;   
end;   
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика