1. написать программу для нахождения числа нечетных элементов в массиве из 10 беззнаковых чисел. 2. написать программу для нахождения числа отрицательных элементов в массиве из 10 знаковых чисел. 3. написать программу для замены всех четных элементов массива из 10 беззнаковых чисел единицами 4. написать программу для замены всех нулевых элементов массива из 10 знаковых чисел единицами. 5. написать программу для замены всех троек в массиве из 10 беззнаковых чисел пятерками.

участник78 участник78    2   09.06.2019 11:40    3

Ответы
zagariyolga068 zagariyolga068  08.07.2020 08:49
Program ex1;

const
  n = 10;

var
  a: array[1..n] of integer;
  kOdd, e, i: integer;

begin
  Randomize;
  kOdd := 0;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    e := Random(20) + 1;
    a[i] := e;
    if (e mod 2) <> 0 then kOdd := kOdd + 1;
    write(e:3)
  end;
  writeln;
  writeln('Количество нечетных элементов - ', kOdd)
end.

Тестовое решение:
Исходный массив   9  2  1 18 17 16 11 15 15 13
Количество нечетных элементов - 7

program ex2;

const
  n = 10;

var
  a: array[1..n] of integer;
  kNeg, e, i: integer;

begin
  Randomize;
  kNeg := 0;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    e := Random(21) - 10;
    a[i] := e;
    if e < 0 then kNeg := kNeg + 1;
    write(e:4)
  end;
  writeln;
  writeln('Количество отрицательных элементов - ', kNeg);
end.

Тестовое решение:
Исходный массив   -9  -1  -7  -4   8  -4   1  -1  -7   0
Количество отрицательных элементов - 7

program ex3;

const
  n = 10;

var
  a: array[1..n] of integer;
  e, i: integer;

begin
  Randomize;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    a[i] := Random(20);
    write(a[i]:4)
  end;
  writeln;
  write('Результирующий массив ');
  for i := 1 to n do
  begin
    if a[i] mod 2 = 0 then a[i] := 1;
    write(a[i]:4)
  end;
  writeln;
end.

Тестовое решение:
Исходный массив    3  16   4   1  13   0  14  14  10  18
Результирующий массив    3   1   1   1  13   1   1   1   1   1

program ex4;

const
  n = 10;

var
  a: array[1..n] of integer;
  e, i: integer;

begin
  Randomize;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    a[i] := Random(11) + -5;
    write(a[i]:4)
  end;
  writeln;
  write('Результирующий массив ');
  for i := 1 to n do
  begin
    if a[i] = 0 then a[i] := 1;
    write(a[i]:4)
  end;
  writeln;
end.

Тестовое решение:
Исходный массив    4  -5   0  -2  -4  -5  -2   0  -1  -5
Результирующий массив    4  -5   1  -2  -4  -5  -2   1  -1  -5

program ex5;

const
  n = 10;

var
  a: array[1..n] of integer;
  e, i: integer;

begin
  Randomize;
  write('Исходный массив ');
  for i := 1 to n do
  begin
    a[i] := Random(10) + 1;
    write(a[i]:3)
  end;
  writeln;
  write('Результирующий массив ');
  for i := 1 to n do
  begin
    if a[i] = 3 then a[i] := 5;
    write(a[i]:3)
  end;
  writeln;
end.

Тестовое решение:
Исходный массив   8  9  6 10 10  7  1  3  1  3
Результирующий массив   8  9  6 10 10  7  1  5  1  5
ПОКАЗАТЬ ОТВЕТЫ
anastasiaruabenko anastasiaruabenko  08.07.2020 08:49
Mov ax, 8
mov bx, 7
mov cx, 56
loop m2:
jmz ll
const as, bl, mz
ll:
m23:
jjk ax, 0
const w, f
conf dw, 8
conf df, w
massiv kkk 1/1, 2/2, 4/4.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика