№1. дана последовательность целых чисел. напишите программу, подсчитывающую, сколько в этой последовательности отрицательных чисел. №2. дана последовательность целых чисел. напишите программу, вычисляющую сумму положительных чисел.

axieva35 axieva35    2   13.05.2019 18:30    9

Ответы
Рыжик151 Рыжик151  10.06.2020 02:04
№1                                        

program raf105;

var a,otr: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 if a<0

   then otr+= 1;

until a = 0;

writeln('Отрицательных чисел: ',otr);

end.

№2                                        

program raf105;

var a,sum: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 if a>0

   then sum+= a;

until a = 0;

writeln('Сумма положительных чисел: ',sum);

end.

                                              PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика