Составить программу в паскале: из n введенных чисел найти максимальное значение среди положительных элементов.

aibarealmadrid aibarealmadrid    2   11.06.2019 13:10    2

Ответы
Mynir Mynir  09.07.2020 13:29
Текст программы в документе.
ПОКАЗАТЬ ОТВЕТЫ
альбертино1 альбертино1  09.07.2020 13:29
Program abc;
type 
   mas = array[0..1000] of integer;
var 
   a: mas;
   i, n, max: integer;
begin
  WriteLn('Введите кол-во эл-тов массива:');
  ReadLn(n);
  for i := 1 to n do
  begin
    WriteLn('Введите значение элемента №', i);
    ReadLn(a[i]);
  end;
  WriteLn('Все элементы массива имеют значение');
  max := -1;
  for i := 1 to n do
    if a[i] > max then
      max := a[i];
    if max <> -1 then
      Writeln('Максимальное значение положительного элемент = ', max)
    else Writeln('Положительных элементов нет');
    ReadLn;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика