1.дан одномерный массив.найти произведение элементов массива кратных 3,нужно в pascale программу вот эту написать 2.подсчитать средний за экзамен по у учащихся,сдавших его.тоже через программу паскаль написать программу.

Stepanych2017 Stepanych2017    3   01.06.2019 14:40    4

Ответы
Malıw Malıw  02.07.2020 17:54
1)
uses crt;
const size = 10;
var a:array [1..size] of integer;
     i,p:longint;
begin
  p:=1;
  randomize;
  for i:=1 to size do
    begin
      a[i]:=random(20);
      write (a[i],' ');
      if (a[i] mod 3 = 0) then p:=p*a[i];
    end;
  writeln;
  writeln (p);
end.

2)
uses crt;
const size = 10;
var a:array [1..size] of integer;
     i:integer;
     s:real;
begin
  s:=0;
  randomize;
  for i:=1 to size do
    begin
      a[i]:=random(4)+1;
      write (a[i],' ');
      s:=s+a[i];
    end;
  writeln;
  s:=s/size;
  writeln (s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика