1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму его элементов

2) дан одномерный массив найдите минимальный и максимальный элемент и выведите на экран​

Vikasuk Vikasuk    2   31.03.2020 20:15    0

Ответы
zemkina347 zemkina347  12.10.2020 11:03

1)Program massiv;

Var mas:array[1..20] of integer;

a,b,i,sum:integer;

Begin

sum:=0;

For i:=1 To 20 Do

begin

mas[i]:= random(100); {Заполняем массив случайными числами в промежетке от 0 до 99 (можешь изменить промежуток}

write(mas[i],' ');

end;

Writeln('Введите a,b');

Readln(a,b);

For i:=1 To 20 Do

begin if (mas[i]>a) and (mas[i]<b) Then

sum:=sum+mas[i];

end;

Writeln(sum);

end.   

ПОКАЗАТЬ ОТВЕТЫ
valikotura valikotura  12.10.2020 11:03

1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму его элементов

1)Program massiv;

Var mas:array[1..20] of integer;

a,b,i,sum:integer;

Begin

sum:=0;

For i:=1 To 20 Do

begin

mas[i]:= random(100);

в промежетке от 0 до 99 }

write(mas[i],' ');

end;

Writeln('Введите a,b');

Readln(a,b);

For i:=1 To 20 Do

begin if (mas[i]>a) and (mas[i]<b) Then

sum:=sum+mas[i];

nd;

Writeln(sum);

end.   

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика