1). дан миссив из n целых чисел. напишите программу определяющую сколько в массиве четных чисел, 2). дан массив из n целых чисел. напишите программу определяющую каких элементов в точке больше положительных или отрицательных

lotoskei lotoskei    2   03.06.2019 14:40    11

Ответы
ksu2407 ksu2407  01.10.2020 18:31
Program BiFi;
Const n=50;
Var A:array[1..n] of integer;
i,c,l:integer;
Begin
for i:=1 to n do readln(A[i]);
c:=0;
for i:=1 to n do if A[i] mod 2 = 0 then c:=c+1;
writeln(c);
readln;
end.

Program BiFi;
Const n=50;
Var A:array[1..n] of integer;
i,k,l:integer;
Begin
k:=0;
l:=0;
for i:=1 to n do begin readln(a[i]);
                      if A[i]<0 then k:=k+1 
                                  else if A[i]>0 then l:=l+1;
                      end;
if k>l then writeln('больше положительных')
        else if l>k then writeln('больше отрицательных')
                       else writeln('одинаково');
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика