с Python! Напишите программу, на вход которой непрерывно (в цикле) подаются введены пользователем данные. При введении каких-либо данных, кроме целых чисел, выводится сообщение об ошибке с генерирования исключения ValueError. Как только ввели целое число, выводится сообщение True и происходит выход из программы.

XASSA XASSA    1   07.06.2021 13:22    1

Ответы
ALexus67 ALexus67  07.07.2021 13:25

прикрепляю файл с рабочим кодом. При желании можно в  блоке except в строке print ввести любое выражение, которое должно появляться при некорректном значении.

while True:

   x=input()

   try:

       x=int(x)

       print('True')

       break

   except ValueError:

       print('ValueError')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика