РЕШИТЬ Напишите программу, которая считывает последовательность из 10 целых чисел и определяет является ли каждое из них четным или нет.

Формат входных данных

На вход программе подаются 10 целых чисел, каждое на отдельной строке.

Формат выходных данных

Программа должна вывести строку «YES», если все числа четные и «NO» в ином случае.

Sample Input 1:

2

4

6

8

10

12

14

16

18

20

Sample Output 1:

YES

Sample Input 2:

1

2

3

4

5

6

7

8

9

10

Sample Output 2:

NO

РЕШИТЕ ОЧЕНЬ НАДО ОЧЕНЬ А ТО МНЕ КАПЕЦ ОТ РОДОКОВ

romka199811p0bu18 romka199811p0bu18    3   07.02.2021 17:43    199

Ответы
Samoilov2903 Samoilov2903  09.03.2021 17:48

result = 'YES'

for i in range (0,10):

 if (int(input()))%2 != 0: result = 'NO'

print(result)

Или можно ещё так, чтобы ошибки входных данных отлавливать:

i = 0

result = 'YES'

while i<10:

 try:

   if (int(input()))%2 != 0: result = 'NO'

   i+=1

 except ValueError:

   print('Неверный формат входных данных. Вводите целое число.')

print(result)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика