Написать программу на c# "произвести суммирование натуральных чисел 1, 2, пока их сумма s не станет равной или превысит величину h. вывести на экран последнее слагаемое и значение суммы."

Юлиана95631 Юлиана95631    3   04.10.2019 05:30    2

Ответы
NastyaPaz NastyaPaz  02.09.2020 17:02

Написал на c++ т,к синтаксис шарпа не знаю, можешь переделать под себя.

#include "pch.h"

#include <iostream>

using namespace std;



int main()

{

setlocale(LC_ALL, "rus");

int summa = 0;

int h;

int i = 1;

cout << "Введите h" << endl;

cin >> h;

for(i;summa<h;)

{

 summa += i;

 i++;

}

cout <<"Сумма= "<< summa << endl <<"Последнее слагаемое = "<< i - 1 << endl;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика