C++напишите программу, которая заполняет массив из n элементов членами арифметической прогрессии с начальным значением x и разностью d в обратном порядке, так чтобы последний элемент был равен x . входные данные входная строка содержит три целых числа: начальное значение x , разность d и размер массива n , разделённые пробелом. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести содержимое массива: n первых членов арифметической прогрессии с начальным значением x и разностью d в обратном порядке, так что последний элемент массива равен x . примеры входные данные 5 3 6 выходные данные 20 17 14 11 8 5

saidovabduraxm saidovabduraxm    2   22.07.2019 12:50    25

Ответы
Дания29 Дания29  23.09.2020 16:28
#include<iostream>using namespace std;int main(){ int n,x,D; cin>>x>>D>>n;int a[n];a[n]=x;for(int i=n-1;i>0;i--){a[i]=x+D;x=a[i];}for(int i=1;i<=n;i++)
cout<<a[i]<<' ';return 0;}
C++напишите программу, которая заполняет массив из n элементов членами арифметической прогрессии с н
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика