Знаете)) надо 1) составьте программу, определяющую превысил ли водитель допустимую скорость на участке дороги 2)составьте программу, определяющую является ли треугольник с заданными сторонами равносторонним. примечание: составное условие на языке паскаль записывается следующим образом: союзу или соответствует or союзу и соответствует and 3) составьте программу, которая находит наибольшее из 2 заданных чисел.

zkudaybergen zkudaybergen    3   18.06.2019 09:10    3

Ответы
SForest SForest  15.07.2020 01:21
3)
var x, y, min, max: real;
label M1;
begin
write('x=');
readln(x);
write('y=');
readln(y);
If x>y then
begin
min:=x;
max:=y;
goto M1;
end
else
min:=y;
max:=x;
goto M1
M1: writeln('min=', min:8:3, ' max=', max:8:3);
end.
2) var a, b, c: real;
begin
write('a=');
readln(a);
write('b=');
readln(b);
write('c=');
readln(c);
If (a=b) and (b=c) then
begin
writeln('Треугольник равносторонний');
end
else
writeln('Треугольник неравносторонний');
end.
1) var a, b: real;
begin
write('Допустимая скорость =');
readln(a);
write('Скорость водителя =');
readln(b);
If (a=b) or (a>b) then writeln('Водитель не превысил скорость');
If a<b then writeln('Водитель превысил скорость');
end.

Я надеюсь, что я правильно поняла задание первой и второй задачи о:
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика