Здраствуйте нужно решить , расписав её для паскаля вот сама - дан массив из n элементов.написать программу, уменьшающую все элементы массива на единицу.

eleniuuum eleniuuum    1   13.06.2019 20:40    3

Ответы
chorna202 chorna202  10.07.2020 18:20
Var a: array of integer; // Объявление массива целых чисел
  i, n: integer; // объявление целочисленных переменных
begin
  // Запросим с клавиатуры размер массива
  // и запишем его в переменную n
  write('введите n:'); 
  readln(n);
  
  // Теперь выделим память под n элементов массива
  SetLength(a, n);
  
  // теперь запросим с клавиатуры n чисел для массива
  for i := 0 to n-1 do begin
    write('a[', i, ']=');
    readln(a[i]);
  end;
  
  // теперь в цикле уменьшим каждый элемент на единицу
  for i := 0 to n-1 do 
    a[i] := a[i] - 1;
  
  // распечатаем массив
  for i := 0 to n-1 do 
    write(a[i], ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика