Заполните массив с клавиатуры целыми числами и найдите сумму элементов массива с i1-го по i2-й (i1 и i2 вводить с клавиатуры). входные данные: в первой строке целое число n (0 < n ≤ 100) - кол-во элементов в массиве и целые числа i1 и i2 (0 < i1, i2 ≤ 100). во второй строке целые числа х1, разделенные пробелом (числа по модулю не превосходят 32000) - значения элементов массива. выходные данные: сумма элементов массива c номерами от i1 до i2. (написать программу на паскале)

ilnitskiy ilnitskiy    1   24.05.2019 22:50    1

Ответы
geralis728p0bgjl geralis728p0bgjl  20.06.2020 21:23
Var
 a:array [1..100] of longint;
 N,i1,i2,i,S:longint;
begin
 Read(N,i1,i2);
For i:=1 to N do Read(a[i]);
For i:=i1 to i2 do S:=S+a[i];
Write(S);
end.
ПОКАЗАТЬ ОТВЕТЫ
vlad270329p08pha vlad270329p08pha  20.06.2020 21:23
За такую программу писать лень:D
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика