tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Заполнить массив из 15 случайных
Заполнить массив из 15 случайных чисел так чтобы числа не повторялись
Wwwoxanap2013
1 01.09.2019 02:50
3
Ответы
yana4ka3
06.10.2020 08:55
// Дядя_Ваня_2011-11-26
#include <iostream>
#include <ctime>
using namespace std;
#define N 15
void main()
{
int a[N];
do
{
system("cls");
srand((unsigned) time(NULL));
cout << endl;
for (int n = 0; n < N; n++)
{
a[n] = 1 + rand() % 15;
for (int m = 0; m < n; m++)
{
if (a[n] == a[m])
{
n--;
break;
}
}
}
for (int n = 0; n < N; n++) cout << ' ' << a[n];
fflush(stdin);
cin.get();
}
while (true);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
igornagornov0
16.07.2019 14:40
Водной из кодировок unicode каждый символ кодируется 32 битами. определите размер следующего предложения в данной кодировке. конец аллеи опять с утра исчез в пыли,...
умник1235678
16.07.2019 14:40
Трёхзначное число, записанное в шестнадцатеричной системе счисления, увеличивается втрое от перестановки первой цифры в конец числа. определите все такие числа. ответ...
summercik2009oziid6
11.08.2019 13:36
Надо перевести числа 1100; 11; 1; из двоичной в восьмеричную систему счисления...
nail4iklatyopo
11.08.2019 13:42
Надо числа в двоичном коде 11; 1; ; 1100 написать в восьмибитном представлении....
ksuholina
13.09.2020 09:57
1. Сравни (поставь знак отношения , или =) 1536 бит или 1,5 Кбайт. 2. Чему равен 1 Петабайт? 3. Сколько бит содержится в 18,25 байтах? 4. Сколько байт содержится в...
LolGameHD
13.09.2020 09:57
не сложно Укажи, в какой папке хранится письмо. Полученные письма хранятся в папке под названием-- 1). отправленные. 2). корзина 3). водящие ←моё мне ние (2) Реши...
amina24569
13.09.2020 10:00
Перед вами выложены n карточек слева направо. i-я слева карточка имеет цвет с: если карточка красная, w, если карточка белая. вы можете делать операции двух типов...
3456801
29.07.2019 18:30
Определите значение переменной c после выполнения следующего фрагмента программы: a : = -2; b : = -3; a : = b + a*3; if a b then c : = a - b else c : = b – a;...
Даша12345н
03.12.2020 13:02
Представление рационального числа в виде бесконечной десятичной периодической дроби. Перевод бесконечной периодической десятичной дроби в обыкновенную дробь. Урок...
вика3876
03.12.2020 13:02
найдите площадь прямоугольника...
Популярные вопросы
составить очень краткий пересказ (2 предложения на англ. языке)...
1
1-Тапсырма • Мәтінді оқып шығып, көтерілген басты мәселені анықтаңыз....
1
E YOb ( 121,33E YO6 ( 48, 52,84) математика...
3
Эсэ на тему Великое переселение турков срачно...
2
Степень изрезанности береговой линии Тихого океана характеризуется......
3
Выпишите строки которые подходят к иллюстрации искандер наме...
1
Төрт разрезан на 4 части верно ли что каждая часть 1/4часть торта...
3
Сколько воды, взятой при, при температуре 10 °С, можно нагреть...
2
Подчеркните все члены предложения 1.Развесистый дуб на холме зеленеет....
1
Why don’t people feel safe despite the incredible progress in medical...
3
#include <iostream>
#include <ctime>
using namespace std;
#define N 15
void main()
{
int a[N];
do
{
system("cls");
srand((unsigned) time(NULL));
cout << endl;
for (int n = 0; n < N; n++)
{
a[n] = 1 + rand() % 15;
for (int m = 0; m < n; m++)
{
if (a[n] == a[m])
{
n--;
break;
}
}
}
for (int n = 0; n < N; n++) cout << ' ' << a[n];
fflush(stdin);
cin.get();
}
while (true);
}