Запишите соотношение, используемое в ниже подпрограмме procedure f(n: integer); begin if n> 1 then begin f(n div 2); end; write ('**'); end; определите, сколько звездочек будет выведено в результате вызова f(7) подпрограммы

татьянаивановна1 татьянаивановна1    1   20.08.2019 21:10    13

Ответы
dashaKrylova41 dashaKrylova41  14.08.2020 17:49
Это рекурсивный вызов процедуры.  При первом вызове F(7)  по условию 
if n>1 then ...  будет вызов этой же процедуры    f(n div 2);  или  f(3),  далее,  т.к. 3>1,  то снова будет вызвана процедура  f(3 div 2)  или f(1),  теперь не выполняется условие  n>1,  следовательно, будет выполнен оператор      write ('**');  -  напечатаются две звездочки, после выхода из процедуры продолжится выполнение процедуры при втором вызове - будут напечатаны еще 2 звездочки, затем продолжится выполнение при первом вызове - еще будут напечатаны 2 звездочки.  В результате вызова f(7) будут напечатаны 6 звездочек  .
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика