tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Запишите программу на языке
Запишите программу на языке паскаль которая заполняет массив случайными числами на отрезке от -2 до 2 и считает сумму положительных элементов массива
shamsutdinovaa3
1 13.09.2019 10:20
4
Ответы
lui19
21.08.2020 07:24
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-2,2); a.Println;
Writeln('Сумма положительных равна ',a.Where(t->t>0).Sum)
end.
Пример
n= 10
-1 1 0 2 2 -1 -2 -1 -1 2
Сумма положительных равна 7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
AnyMaskelyne
09.08.2019 17:30
Нужно решение сколько бит информации содержит сообщение объемом 128 килобайт?...
ely4
28.04.2019 18:15
Люди придумайте сказку про информатику 7-10предложений...
nogtev70
28.04.2019 16:19
Решить на pythoneвходные данныена первой строке дано число n. на последующих строках подается на вход n чисел, записанных в отдельных строках.выходные данныетребуется...
boldarev2001
28.04.2019 16:21
Счего начинается запись формулы в ячейку электронной таблицы? a) * b) = c) f(x) d) y=...
Vasya1godik
28.04.2019 16:27
Дан целочисленный массив из 30 элементов. элементы массива могут принимать целые положительные значения от 1 до 10 000 включительно. напишите на языке программирования...
SlavaArt
22.05.2019 19:10
Написать программу, которая получает возраст человека от 0 до 120 лет и выводит со словом год , года , лет ....
vitalia4420
21.05.2020 22:08
Укажите количество решений неравенства 123/8 ≤ Х ≤ В8/16...
ksuholina
21.05.2020 22:08
Контрольная работа №4 «Растровая и векторная графика. Кодирование графической информации» Вариант № 1 1) Растровые изображения формируются из… 1. Пикселей 2. Графических...
Ник111111н
21.05.2020 22:08
Надрукуйте всі цілі числа з інтервалу [120; 150]Знайти всі трьохзначні числа, сума цифр яких дорівнює числу A.На Паскале...
aydin123
20.05.2019 00:00
Найдите знаменатель прогрессии: 7,1/√7,1/...
Популярные вопросы
В течение нескольких мгновений блеснули лучи утреннего света, рассеявшие...
1
Здравствуйте с геометрией очень важно! Заранее Выручайте....
2
Чтобы увидеть ледники своими глазами туристы купили билеты на автобус...
1
Какую роль в описании дома Плюшкина играют слова: ветхость, старый,...
3
Изобразительно-выразительные средства раскрывающие образ ярилы...
3
Решите уравнение методом вс угла 1. 2sinx - 3cosx = 1/2; 2. 3sinx...
2
Какова масса воздуха на высоте 12 км , 40 км?...
2
Написать эссе на тему «Кому выгодна конкуренция в рыночной экономике»....
1
подвесом два груза на правой части рычага на расстоянии равном...
2
Какое действие Австрии сыграло значительную роль при бое на Чертовом...
3
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-2,2); a.Println;
Writeln('Сумма положительных равна ',a.Where(t->t>0).Sum)
end.
Пример
n= 10
-1 1 0 2 2 -1 -2 -1 -1 2
Сумма положительных равна 7