tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Записать алгоритм и написать
Записать алгоритм и написать программу циклического перемещения влево значений между переменными а, b, c
fidan191
1 30.05.2019 02:30
4
Ответы
НИКвсе
29.06.2020 18:33
Program gt;
var a,b,c,k:integer;
begin
read(k);
{k-на какое число шагов надо переместит числа a b c влево}
k:=k mod 3;
if(k=0)then writeln(a,' ',b,' ',c);
if(k=1)then writeln(b,' ',c,' ',a);
if(k=2)then writeln(c,' ',a,' ',b);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kat247
01.04.2019 18:25
Написать программу по определению четности или нечетности числа. число вводится с клавиатуры. 17+9...
ната12354
01.04.2019 20:10
Вкоробке лежат 32 карандаша. сообщение о том, что достали зеленый карандаш, несет 2 бита информации. сколько зелёных карандашей в коробке?...
Qwertyttt
01.04.2019 18:22
Нужно разбить код на методы c#ссылка на само , код рабочий, но длинный:...
dinka1820
01.04.2019 20:10
Дети в 4 кассе должны читать 170 символов в минуту.предположим, что при записи текста использовался 32 символьный алфавит. какой объём информации должен получить ребёнок,...
MishaDunaev
04.02.2021 21:30
Найти количество информации, которое занимает видеоролик, размером картинки 800*600 пикселей, с частотой кадров 15 кадров/сек, длительностью 1 минута, в цветовой гамме 16...
andreyylysp08r6o
04.02.2021 21:27
Напишите программу НА ПИТОНЕ, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел. Программа получает на вход целые числа, количество...
Шпунтик99
02.12.2020 13:35
ИНФОРМАТИКА Дан одновременный массив -125 200 10 0какой индекс у элемента массива, знаяение которого 0...
denchenchik02
13.05.2020 17:21
Напишите наибольшее целое число, для которого истинно высказывание: (х 38) ИЛИ НЕ (Х 50)?...
Anastasia20181
21.08.2019 04:30
Вms word набери слово жёсткий диск и сохрани его с названием info, указав тип файла word 97 - 2003 document (*.doc) запиши имя данного файла...
eledzheev
15.05.2019 19:35
Ii. complete the following sentences with alan, the, or no article. 1. linda is going to visit england next week.2. he is in fifth form, isn t he? bob is best pupil in his...
Популярные вопросы
- Почему прыжок с места развивает скоростно-силовые...
3
Летние травы!Вот они воинов павших грезы о славе анализ этого хокку...
3
Озаглавь текст. В одной газете появилось шуточное объявление о самом...
2
При каких суффиксов и слов образуются степени сравнения прилагательных?...
1
Прочитай отрывак из текстов. Какой темой они объединены? К художественному...
2
Какое открытие было сделано Шаханом Улихановым...
3
У якому реченні ставити тире перед узагальнювальним словом?1. Я зробив...
2
Найдите координаты точки пересечения отрезка АВ с осью ординат, если...
3
Найти наибольшее и наименьшее значения функции на заданном промежутке:...
2
выполнить английский номер3 надо написать какие виды спорта изображены...
2
var a,b,c,k:integer;
begin
read(k);
{k-на какое число шагов надо переместит числа a b c влево}
k:=k mod 3;
if(k=0)then writeln(a,' ',b,' ',c);
if(k=1)then writeln(b,' ',c,' ',a);
if(k=2)then writeln(c,' ',a,' ',b);
end.