закончить программу с++! Не получается написать программу. Задание такое--->Создать комбинированный (структурный) тип для списка CD-дисков (название альбома, исполнитель, год выпуска, длительность, стоимость). Описать функцию нахождения общей длительности всех музыки на всех дисках в коллекции. Пользователь задает два комбинированных массива по N элементов в каждом.(для двух коллекций). Применить функцию два раза для заданных двух коллекций. . (Так же будет уместно описать процедуру ввода комбинированного массива и процедуру вывода.)

с++ код(не знаю правильно или нет)

#include

#include

using namespace std;

struct sddisc {

string name; //название альбома

float singer; //исполнитель

float time; //год выпуска

float duration; //длительность

float cost; //стоимость

};

int ssddisc(sddisc x[], int n) { //ф-ия находения сам. длительности всех музыки

int num = 0; //номер музыки

float min = x[0].duration;

for (int i = 1; i < n; i++) {

if (x[i].duration > min) //(???)

min = x[i].duration; num = i;

}

return(num);

}

int main(void) {

int n, m;

cout << "vvedite ko-vo el.v 1massive" << endl;

cin >> n;

cout << "vvedite ko-vo el.v 2massive" << endl;

cin >> m;

sddisc* r = new sddisc[n];

sddisc* f = new sddisc[m];

}

Chinchil1a Chinchil1a    3   08.04.2020 20:51    6

Ответы
aliher01 aliher01  12.10.2020 23:09

#include <iostream>

#include <iomanip>

#include <vector>

using namespace std;

struct CD{

   string name;

   string singer;

   int year;

   int duration;

   double cost;

};

signed main() {

   int ans1 = 0,ans2 = 0;

   int n;

   cin >> n;

   CD a1[n],a2[n];

   for(int i = 0; i < n; i++)

       cin >> a1[i].name >> a1[i].singer >> a1[i].year >> a1[i].duration >> a1[i].duration;

   for(int i = 0; i < n; i++)

       cin >> a2[i].name >> a2[i].singer >> a2[i].year >> a2[i].duration >> a2[i].duration;

   for(auto i: a1)

       ans1 += i.duration;

   for(auto i: a2)

       ans2 += i.duration;

   cout << "1 collection durates: " << ans1 << "\n";

   cout << "2 collection durates: " << ans2 << "\n";

   cout << "both collections durate: " << ans1 + ans2 << "\n";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика