Задайте число в интервале от 1 до 100. составьте программу (паскаль), которая: -умножает это число на себя -складывает результат умножения с удвоенным исходным числом -делит полученную сумму на исходное число -вычитает из результата деления исходное число -выводит на экран окончательный результат

Caшa2220 Caшa2220    3   16.09.2019 16:10    13

Ответы
Potap4uk Potap4uk  16.08.2020 17:03
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите число от 1 до 100:');
  Writeln('Получаем ',((n*n+2*n) div n)-n)
end.

Пример
Введите число от 1 до 100: 77
Получаем 2

Замечание.
Сделаем преобразование.
(n*n+2*n)/n-n = n(n+2)/n-n = n+2-n = 2
Всегда будет получаться результат 2.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика