Задать массив и решить var k, m: integer; dat: array[1..11] of integer; begin dat[1] : = 20; dat[2] : = 25; dat[3] : = 19; dat[4] : = 25; dat[5] : = 26; dat[6] : = 22; dat[7] : = 24; dat[8] : = 28; dat[9] : = 26; dat[10] : = 21; dat[11] : = 27; m : = 0; for k : = 1 to 11 do if dat[k] > 22 then begin m : = m + 1 end; writeln(m) end.

Nikia1 Nikia1    1   11.07.2019 22:10    3

Ответы
Polina011020040 Polina011020040  31.07.2020 11:57
// PascalABC.NET 3.0, сборка 1088
const
  Dat:array[1..11] of integer=(20,25,19,25,26,22,24,28,26,21,27);
var
  k,m:integer;
begin
  m:=0;
  for k:=1 to 11 do
  if Dat[k]>22 then Inc(m);
  Writeln(m)
end.

Тестовое решение:
7

А вот так можно написать программу, если знать немного больше, чем дают в школе:

// PascalABC.NET 3.0, сборка 1088
begin
  var Dat:array[1..11] of integer:=(20,25,19,25,26,22,24,28,26,21,27);
  Writeln(Dat.Where(x->x>22).Count)
end.

Но ведь в школе не ищут простых решений! (((
ПОКАЗАТЬ ОТВЕТЫ
ДженниЛенни ДженниЛенни  31.07.2020 11:57
Var k, m: integer;Dat: array[1..11] of integer;
Beginfor k := 1 to 11 do begin
Dat[k]:= random(20)+10;
write(Dat[k]:4);
if Dat[k] > 22 then m := m + 1;
end;
writeln;writeln(m);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика