Заданы два целых числа a и b. составьте программу, определяющую, сколько целых чисел, которые одновременно удовлетворяют двум неравенствам x> a и x

vika27272705 vika27272705    1   30.09.2019 12:20    5

Ответы
Rus9922 Rus9922  09.10.2020 05:25

var a,b:integer;

begin

readln (a,b);

if a<b then write (b-1-a) else write(0)

end.

ПОКАЗАТЬ ОТВЕТЫ
Ангелюся10 Ангелюся10  09.10.2020 05:25

Ввод: a ^ b С/П.

- x>=0 05 0 С/П /-/ 1 - С/П


Согласен, отрицательный результат противоречит условию, исправил. Благодарю за замечание, был невнимателен.

Смысл кода такой:

X = a; Y = b;

X -= Y; Если не (X >= 0), переход на 05; X = 0; Стоп; [05] Смена знака; Y = X, X = 1; X -= Y; Стоп. На индикаторе X.

Рад, что мои решения кому-то интересны.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика