Задано целое число n написать программу которая находит количество 0 в заданном числе

Kristina1605lps Kristina1605lps    2   04.10.2019 13:00    2

Ответы
66PrIvEt66666 66PrIvEt66666  09.10.2020 19:37

//PascalABC.NET v3.3 1633

begin

 var num:=ReadInteger('Введите число: ');

 var sum:=0;

 for var i:=1 to IntToStr(num).Length do

   if IntToStr(num)[i] = '0' then sum += 1;

 writeln('Количество нулей: '+sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Аминка233 Аминка233  09.10.2020 19:37
Java:

Scanner in = new Scanner();
String data = in.nextLine();
int counter =0;
for(char g:data.toCharArray()){
if('0'.equals(g)){
counter++;
}
}
System.out.println(counter);
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика