Заданной двузначное число. Составьте программу с которой определите произведения квадратов цифр этого числа( на языке pascal)

mariakhh2006 mariakhh2006    2   27.02.2020 18:54    1

Ответы
IÎrîskåI IÎrîskåI  11.10.2020 14:46

Язык: Pascal

program z1;

var a, x, y, b: integer;

begin

read(a);

x:= a div 10;

y:= a mod 10;

x:= sqr(x);

y:= sqr(y);

b:= x*y;

writeln('Квадрат первой цифры числа = ', x);

writeln('Квадрат второй цифры числа = ', y);

writeln('Произведение квадратов чисел = ', b);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика