Задание: Напишите программу, которая в последовательности чисел определяет максимальное число, оканчивающееся на 1. На вход программа получает числа: 3, 11, 21, 31. Количество чисел не превышает 1000. Величина чисел не превышает 30000.
Я пишу программу:
var n, a, i:integer;
begin
readln(n);
min(n) :=30001; (вот здесь он ругается "нельзя присвоить левой части")
for i:=1 to n do
begin
readln(a);
if (a mod 16 = 0) and (a then min:=a;
end;
writeln(min);
end.

Что не так??? Объясните И если есть еще ошибки, исправьте

AlinaRoz AlinaRoz    3   14.04.2020 10:46    5

Другие вопросы по теме Информатика