Задание на языке Паскаль: написать программу для вычисления значения переменной Y при условии, если Х> 2, то Y = 2Х, иначе Y = Х + 5. Использовать условный оператор If ...Then ...Else ..

ReutovTema222 ReutovTema222    2   18.03.2020 08:39    5

Ответы
Olegafrey Olegafrey  11.09.2020 21:16

Variant 1

begin

 var x := ReadInteger('Введите X:= ');

 if x > 2 then

   Println('Y:= ', 2 * x)

 else

   Println('Y:= ', x + 5);

end.

Varian 2

var

 x, y: integer;

begin

Writeln('Введите Х: ');

 Read(x);

 if x > 2 then

 begin

   y := 2 * x;

 end

 else

   y := x + 5;

 Write(y);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика